În versiunea gratuită MAMP permite utilizatorului să aleagă între 2 versiuni de PHP. Atât.

Ei bine, asta nu este tocmai “plăcut”, mai ales că mie îmi propunea ori php5.5.10 ori php5.1.6 și eu aveam nevoie să fac ceva teste pe un php5.3.

Soluția pentru a face MAMP (OS X) să te lase să alegi între 2 versiuni preferate de tine este una super simplă.

Tot ce trebuie să faci este să mergi în directorul /Applications/MAMP/bin/php și să redenumesti toate versiunile de care nu ai nevoie momentan adăugând ceva la final (de exemplu php5.1.6 ==> php5.1.6_X). În acest fel vei lăsa doar 2 directoare așa cum erau înainte.

Un restart la MAMP și vei vedea că acum îți va propune să alegi o versiune de php din cele 2 “alese” de tine.

Simplu, nu? E drept, nu este tocmai corect, dar este practic și rapid :)

Soluția am găsit-o pe StackOverflow

2675 Total Views 1 Views Today